Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am using OSGeo Live. It is an Ubuntu system. I installed it in my PC. I was following one pgRouting workshop.

http://workshop.pgrouting.org/index.html

In one step, I needed to connect osm2pgrouting with postgis to import data. But, the commands are not working. It is showing following connection fail error. I did not change anything. All the passwords are as default.

$ osm2pgrouting -file "data/sampledata.osm" \
>                           -conf "/usr/share/osm2pgrouting/mapconfig.xml" \
>                           -dbname routing \
>                           -user postgres \
>                           -clean
host=127.0.0.1 user=postgres dbname=routing port=5432
connection failed
$

I tried to fix it. I edited /etc/postgresql/8.4/main/pg_hba.conf, and change the postgres connection method to trust from indent. But, it does not work. The result is same, as before.

# Database administrative login by UNIX sockets
# indent
local   all         postgres                          trust

Thanks, in advance.

share|improve this question
add comment

1 Answer 1

Which OS are you on.

local means none ip connection, socket connection. That said you may want to add the below since you are connection by ip.

host     all     all     127.0.0.1/32    trust

For ipv6 connection you would need:

host     all     all     ::1/128     trust

(windows 7 for example usually tries to make an ipv6 connection when you put localhost or 127.0.0.1.

Also don't forget you need to do a config reload for settings to take effect

pg_ctl reload

or if you can't find that just restart your postgresql service.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.