Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm using aggregate polygons on a dataset with three large study areas. It did not work. So I split it into separate areas and did it again. Two of the three areas (which were smaller than the third) aggregated correctly. The third I split into municipalities (since it had a few in it) and then aggregated each separately, apart from two, which refused to aggregate. The error message was not forthcoming, it just says "Background processing has encountered a serious error and is unable to continue. And then it allows me to send an error report to ESRI, which I have, though it's been almost innumerous times.

So I used grid index features and made a grid over one municipality and then split the data by that grid. I ended up having to do 5 x 5 km grids (making 42 index polygons) because anything bigger would not process properly. That actually sort of worked, except for five of the grids which would not. I tried vainly to do 'multipart to singlepart' which worked for some of them, though in this case, I had to further subdivide each 5x5 grid into 4 more indices. In that case, quite a few actually processed, but there is one or two stubborn grids which will not process at all and produce the same error.

I even went into each grid's data and used the editing toolbar to merge some of the polygons together manually, before using aggregate polygons.

Has someone else had similar trouble? Are there any workarounds or suggestions? Because I will otherwise have to repeat the process two or three more times (as it is a time-series project).

A comparison screenshot of a subset of the data

edit: I tried dissolve and it does sort-of do what we want, though is there any way to add a distance value to it like aggregate polygons has?

share|improve this question
1  
Dissolve will work better > help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//… –  Mapperz Apr 27 '12 at 14:12
1  
If your dataset is huge Dissolve can use the Tiling for Large Datasets module > help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//… (aggregate cannot) –  Mapperz Apr 27 '12 at 14:14
    
I'm not sure if I can use dissolve because I don't have a field to dissolve by... or should it just be by FID or something? –  Emily Apr 27 '12 at 14:15
1  
Dissolve by Field is Optional –  Mapperz Apr 27 '12 at 14:17
    
Thanks, I'll give it a shot –  Emily Apr 27 '12 at 14:19

1 Answer 1

up vote 1 down vote accepted

Dissolve (Data Management) is a better solution:

Dissolve will work better > http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00170000005n000000

(Dissolve by Field is Optional)

enter image description here

If your dataset is huge Dissolve can use the Tiling for Large Datasets module > http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//000800000014000000 (aggregate cannot)

enter image description here

share|improve this answer
    
Is there a way to make dissolve allow for a distance as in aggregate polygons? –  Emily Apr 27 '12 at 20:44
    
Not without pushing up your cluster tolerance significantly, which would almost certainly give you undesired artefacts (like destroying the shape of your boundaries). To mimic a disolve-over a distance operation you would need to buffer (with the dissolve option selected) and then de-buffer. This is a workable approach in some circumstances but does significantly increase your vertex count (depending on your cluster tolerance) and can 'smooth' some sharp edges. If you have the dissolve option turned on, buffer can also take advantage of the tiling for large datasets mentioned by Mapperz. –  MappaGnosis Apr 30 '12 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.