Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to add time enabled layers into ArcGIS online. The information in the ArcGIS resource center makes it sound like it is possible to add time enabled layers from ArcMap to ArcGIS online. I can get the layer to be time enabled in ArcMap but when I zip the layer and add it to ArcGIS online the time factor is gone. I can see my layer but not play through the time animation. You are suppose to be able to see a description of each layer in ArcGIS online, it seems like the description will tell you if the layer is time enabled or not but this option is greyed out.

Any suggestions on how to animate my layer would be helpful!

share|improve this question
it sounds like you are zipping your shape file and loading that. You should create a layer package and one of the options is to share it to agsonline. I think that will be the difference. – Brad Nesom May 4 '12 at 15:59
I tried that. I can share the layer package but I couldn't figure out how to view it on arcgis online. I found a tutorial,… This makes it look like I have to use an ArcGIS server to upload my time enabled layers – Sarah May 14 '12 at 13:59

From this help link you can only enable time on a temporal map service, image service, or KML layer. Also check out the video on that link

share|improve this answer

First in ArcGIS: You need to make sure your time field is in date format. The geoprocessing tool convert time field will do that. Within the properties of the layer turn on time enabling using the tab field. (not sure if this actually does anything when moving to ArcGIS online since it seems to stay with the map). Then export the data and zip all the shapefile data. Second in ArcGIS online: In my content add the zip folder with all files. Be sure to check the box stating it is a hosted layer. (If this button doesn't appear you may not have proper privileges. Once the file loads click on the layer name then on the small arrow next to the layer name in the new window. From the drop down box "Time Settings" should appear to enable a time scroll.

This is the blog post I used to finally figure this out. He does a great job lining everything out.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.