Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm installing QGIS 1.7.4 in windows 7 & having problems with QSpatialite. I get 3 messages...

Message #1 This DB a valid SQlite DB, but not a valid SpatiaLite DB. QSpatiaLite will now try to Create a valid SpatiaLite DB

then Message #2 Error. Try to execute by yourself: SELECT InitSpatialMetadata()

then Message #3 You are using SpatiaLite V2.3 ( standart with QGIS<1.7). Please note that QspatiaLite full potential require SpatiaLite V2.4. Please update your SpatiaLite version, or move to QGIS 1.7

What I've tried

  1. Executing the SELECT InitSpatialMetadata() command from within the dialog
  2. I'm running QGIS 1.7.4
  3. The QSpatialite dialog confirms the error message because in the bottom left corner it says I'm running Spatialite V2.3.1. Thinking my problem relates Spatialite version, I ran the OSGeo4W setup again. However, the setup says I'm running spatialite 3.0.1-2 and sqlite 3.7.10-2.

The only thing I can think of is that spatialite v3 is not being picked up because the QSpatialite plugin installed v2.3.1 of spatialite somewhere. Is that possible? Any ideas?

Thanks

Ian

share|improve this question
add comment

2 Answers 2

yes, QGIS use SpatiaLite v2, so does QSpatiaLite. Therefore, QSpatiaLite is unable to manage SpatiaLite V3 DB

share|improve this answer
add comment

Qspatialite IS able to manage SpatiaLite v3 DB. You just have to ensure that QGIS is shipped with V3.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.