Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting an extension error when I try and intersect some points and polygons.

enter image description here

Here is a photo of what I am trying to intersect:

enter image description here

Any help is appreciated.

share|improve this question
Are you using geographic coordinates or a projection? If there are no other obvious problems (and based on comments it sounds like there are not), I would try using a projection. – djq May 13 '12 at 16:19
Is "extension error" a typo? If so, could be worth correcting. – PolyGeo May 14 '12 at 1:02

I suspect that your input files are in two different coordinate systems. I don't think that intersect does a projection-on-the-fly prior to intersection. A visual inspection won't reveal this, ensure that they have the same coordinate system.

share|improve this answer
This is not true. At least in ArcGIS 10.0. Possibly in previous versions but I am not sure. I have tried it using two layers even with different GCP which needs transformation method - intersection is working OK. So, it does projection-on-the-fly. – Alex Markov May 13 '12 at 15:24
I have had the problem that Dan describes on ArcGIS 9.1 & 9.3 (not certain if it exists on ArcGIS 10.0). – djq May 13 '12 at 16:07
Interesting. At least they fixed it in 10.0 :) – Alex Markov May 13 '12 at 16:11
A screenshot of the Coordinate System tab from the Data Frame Properties with these two Layers expanded would give us a chance to see what coordinate system(s) the underlying data is stored in. – PolyGeo May 14 '12 at 5:24

Actually, it is said there that your points and polygons don't intersect at all and thus you have "empty output".

You can check intersection visually by loading both layers - do you see any point inside polygons? Also check your intersection settings when running Intersect tool.

share|improve this answer
Here is a photo of what I am trying to intersect. The coordinate systems are the same. I add an excel sheet then click on display XY data and select the same coordinate system as the polygons. Everything looks exactly like it's supposed to. Not sure what I am doing incorrectly. Thank you for your help! – and_by May 13 '12 at 16:01
Have you tried to save XY data (points) to external feature class (shp, GDB) ? and then use it the Intersect tool. – Alex Markov May 13 '12 at 16:10
Yuppers. That's how I am able to keep the table attributes. When I save as a shp file. Here are two more photos when I try to investigate the intersection error. I have no idea what they mean. – and_by May 13 '12 at 16:14
Have you set any Environment Variables before executing Intersect tool? What coordinate system is used for your data? – Alex Markov May 13 '12 at 16:23
I have not set any variables. I tried setting the XY variables to decimal degrees which is what they are for both the polygons and points. But it made no difference. – and_by May 13 '12 at 16:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.