Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

after a routine system update my qgis got lost (xubuntu 12.04). After trying to reinstall 1.7.4 this massage apears in Softwarecenter (german):

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

qgis: Depends: libc6 (>= 2.4) aber 2.15-0ubuntu10 soll installiert werden
      Depends: libgcc1 (>= 1:4.1.1) aber 1:4.6.3-1ubuntu5 soll installiert werden
      Depends: libgsl0ldbl (>= 1.9) aber 1.15+dfsg-1build1 soll installiert werden
      Depends: libpq5 (>= 8.4~) aber 9.1.3-2 soll installiert werden
      Depends: libqt4-network (>= 4:4.5.3) aber 4:4.8.1-0ubuntu4.1 soll installiert werden
      Depends: libqt4-sql (>= 4:4.5.3) aber 4:4.8.1-0ubuntu4.1 soll installiert werden
      Depends: libqt4-svg (>= 4:4.5.3) aber 4:4.8.1-0ubuntu4.1 soll installiert werden
      Depends: libqt4-xml (>= 4:4.5.3) aber 4:4.8.1-0ubuntu4.1 soll installiert werden
      Depends: libqtcore4 (>= 4:4.7.0~beta1) aber 4:4.8.1-0ubuntu4.1 soll installiert werden
      Depends: libqtgui4 (>= 4:4.6.1) aber 4:4.8.1-0ubuntu4.1 soll installiert werden
      Depends: libqtwebkit4 (>= 2.2~2011week36) aber 2.2.1-1ubuntu4 soll installiert werden
      Depends: libstdc++6 (>= 4.6) aber 4.6.3-1ubuntu5 soll installiert werden
      Depends: qgis-providers (= 1.7.4-1~oneiric1) aber 1.7.4-1~oneiric1 soll installiert werden
      Depends: qgis-common (= 1.7.4-1~oneiric1) aber 1.9.90+git20120511+6678c75~precise1 soll installiert werden

After trying to install qgis in terminal, that appears:

root@MAP-PC:~# apt-get install qgis
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 qgis : Hängt ab von: qgis-providers (= 1.7.4-1~oneiric1) soll aber nicht installiert werden
        Hängt ab von: qgis-common (= 1.7.4-1~oneiric1) aber 1.9.90+git20120511+6678c75~precise1 soll installiert werden
        Empfiehlt: qgis-plugin-grass soll aber nicht installiert werden
        Empfiehlt: python-qgis soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
root@MAP-PC:~# 

Seems, some dependencies are missing, but that makes no sense for me! The same happend with qgis-masters. What Iam doing wrong?

Thanks! Martin

share|improve this question
    
Did you uninstall 1.8 before trying to reinstall 1.7.4, Martin? I'm not sure it's a good idea to have both installed at the same time (it caused problems for me). Nick. –  nhopton May 13 '12 at 17:47
    
Yes, I uninstalled it before. –  MAP May 14 '12 at 6:31
add comment

1 Answer 1

I solved the problem: I had to totaly remove my old qgis 1.9 (aptitude), and change the software source to:

deb     http://qgis.org/debian-nightly precise main
deb-src http://qgis.org/debian-nightly precise main

(did the source-path change in the last days?)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.