Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to batch process about ten files using a model I created. There are five model parameters, which I can fill in for the first feature class without a problem. However, when I try to fill in the output file information for the subsequent feature classes, the model "remembers" the values for the first feature class and changes it. For example, for the output for the intersect of fc1, I specify fc1_intersect. Likewise with fc2, I specify fc2_intersect. As soon as I click away to fill in the next values, the output of fc2's intersect will be changed to the same as fc1's intersect.

This causes the model to fail. I have not specified any default output locations or anything. I used to have a similar problem in ArcMap, where the tools would "remember" the previous layers used, but closing and reopening it would solve it. This is not working now with ArcCatalog, and the time I was hoping to save by batch processing is now being wasted trying to figure out why it keeps changing my input.

share|improve this question
How are you running Batch processing? Can you execute your model successfully at least once? – Alex Markov May 16 '12 at 8:30
Along the same lines as Alex's comment, am I right to assume that if you ran your model twice using different file inputs then the model would work as you expect? And that it only starts filling in the wrong output values when the model is run by right-clicking on it in the toolbox and choosing Batch? – PolyGeo May 16 '12 at 10:27
Correct - the model executes successfully by itself, and if I run it on each input separately it works perfectly. When I right click, Batch, and start filling in the values, that's when it starts ignoring what I fill in and replaces it with the values of the first entry. – Cindy Williams-Jayakumar May 16 '12 at 11:54

I tried to reproduce this problem in ArcGIS Desktop 10.0 SP4 by creating a simple model that contained just two things: a Copy Features tool; and a Variable of type Feature Class that I made into a Parameter.

The model looks like this: enter image description here

When run normally the tool dialog looks like this: enter image description here

The Batch Dialog looks like this and behaved itself as I entered output feature classes. Batch Dialog

I think the above has captured the crux of your workflow and am hoping that by looking at it you may be able to find something that is different from your actual workflow to home in on the cause of your problem.

share|improve this answer
have you attached an image? I cannot see it, though I suspect this is because I am being forced to use Internet Explorer. I'll check back later. – Cindy Williams-Jayakumar May 18 '12 at 5:08
Answer I gave has 3 images included and I just changed text very slightly to be clear those images are above my last sentence. – PolyGeo May 18 '12 at 7:24
Could you attach links to the images please? – Cindy Williams-Jayakumar May 24 '12 at 5:29
up vote 0 down vote accepted

It would appear that the answer I am looking for is here. As in example 1, I need to specify the output as an inline variable within my model, to stop it from overwriting my previous outputs (similar to Using the %i% system variable with in-line variable substitution.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.