Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am creating a flyover animation in ArcScene and I would like my surface raster to be rendered in full resolution (an exported function raster dataset - a blend of shaded relief and high resolution imagery)

I've tried to export several clips with the function raster dataset itself but the uncompressed AVI output was quite jerky. I then converted the function raster dataset into TIFF and the output video did not improve.

Will Converting to FGDB Grid or any other grid make a difference in the final animation rendering. It plays smoothly in ArcScene itself; it's only the exported uncompressed video that seems to be quite jerky. Any other recommendations?

EDIT: What I meant by the above statement "I would like my surface raster to be rendered in full resolution" was not a question but a statement; this raster is set and must remain set to preserve detail to HIGH (Quality Enhancement for Raster Images: HIGH)

After reading the first question (thanks @GIS-Jonathan) I realized that I might want to include my machine specs:

  • Intel Core i7-980X Extreme Edition 3.33Ghz CPU
  • OCZ DDR3 PC3-6GB RAM (12GB total)
  • Asus P6X58D Premium Motherboard
  • WD VelociRaptor 450 GB, SATA 6 Gb/s, 32 MB Cache, 10,000 RPM Hard Drive
  • NVIDIA Quadro 4000 w/2.0GB, Dual Link DVI Video Card
  • Windows 7 Professional 64bit
share|improve this question
    
Those are very high specs but depending on the video-resolution even that won't be able to keep up with uncompressed video. If you want to test the compression theory - upload it to YouTube and see what that makes of it. –  GIS-Jonathan May 18 '12 at 14:51
    
already did that - YouTube made the video black and white, made a terrible artifact on the left and altough the video is smoother, jerks are still present... Take a look –  Jakub May 18 '12 at 14:56
    
Heh. I get "an error occured, please try again later". :-) You may wish to try vimeo.com, but other than that if compressing doesn't work (I'd use either xvid or x264 myself using VirtualDub) I'm stumped –  GIS-Jonathan May 18 '12 at 15:02
    
The YouTube vid looked pretty smooth to me. Other than the artifact, it seemed ok. –  user3461 May 18 '12 at 15:03
    
thanks for your help @GIS-Jonathan. I've done a bunch of videos before but none is completely fluid. I use CyberLink Power Director 10 for assembling my flyovers and exporting to final product. I've tried every possible codec and uncompressed combination that it allows including x264 and although it helps a little bit it also removes a lot of detail and saturation from the video. –  Jakub May 18 '12 at 15:09

2 Answers 2

up vote 2 down vote accepted

The uncompressed AVI output was quite jerky

There's a very good chance this has nothing to do with the quality of the video itself but that it is uncompressed. Uncompressed video is very large and I'd guess your computer simply isn't capable of reading it from the drive fast enough to be able to render it properly. A simple 1280*720 requires about 530 Megabits per second after all!.

The solution here therefore is to compress the video. This doesn't need to result in much of a drop in video quality depending on the codec and settings used. Wikipedia does of course have a page for Comparison of video editing software which will let you do this, as might - https://en.wikipedia.org/wiki/Comparison_of_video_encoders.

Alternatively: Cheat

If the scene renders fluidly in ArcScene, rather than use ArcScene's renderer, cheat and use a screencapturing program to capture the smooth flyby. - https://en.wikipedia.org/wiki/Comparison_of_screencasting_software

Note: I don't believe changing the raster format will be of any assistance.

share|improve this answer
    
Thanks; the first part is not a question but a statement - just wanted to make sure it is understood that the quality enhancement for raster images is set to HIGH. I will try to import the uncompressed video to a movie editor and export from there. The last time i did this the "jerks" were lessened but still present. i will also post my machine specs. –  Jakub May 18 '12 at 14:41
    
@Jakub - there's also - forums.arcgis.com/threads/… - but in my experience the video output won't be jerky even if ArcScene renders itself as jerky because of the way ArcScene works behind the scenes. If you're still getting jerkyness post-compression I'd be curious to know what sort of "compression" & codec settings etc you're using. –  GIS-Jonathan May 18 '12 at 14:47
    
I will transfer this to another machine with similar specs but an SSD and see what happens. BTW this is a common problem, i've seen similar posts on the arcgis forums. –  Jakub May 18 '12 at 15:00
    
SSD's don't have much more throughput than HDD's (they're made for latency and video playback is a latency thing), but worth a try. I've just added a second alternative answer - cheat! :-) –  GIS-Jonathan May 18 '12 at 15:08
    
I agree that it is doubtful that changing the raster format will help much. –  user3461 May 18 '12 at 15:14

Lowering the frame rate of your output may result in smoother playback. This may seem counter-intuitive, but if the playback device has less frames to calculate, the result will be smoother.

This will only be true if you aren't already using a low frame rate. I would start at 24 fps then adjust up or down from there.

Note that you may only be able to change the frame rate with certain codecs/output formats.

share|improve this answer
    
Further to this - you can use Fraps (fraps.com) to determine what the actual playback rate is. Most good video players (i.e. MPlayer, VLC) allow you to see what the frame-rate of the actual video is in the properties somewhere. –  GIS-Jonathan May 18 '12 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.