Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Garmin BaseCamp recognizes and receives data from my GPSmap 60CSx, but QGIS GPS Tools plugin does not. Am I missing a step? I want to be able to transfer data both directions.

MacOS 10.6.8 QGIS 1.7.2

share|improve this question
add comment

2 Answers

@Gray, first, upgrade to QGIS 1.7.4-4, if you can. Transferring data, via the GPS Tools, leverages the GPSBabel tool. When debugging a GPS (that appears to not be working with QGIS) it is best to start with GPSBabel and see if it connects and downloads data in .gpx format, which can be added to QGIS via the GPS Tools directly.

You're in luck, many users of more recent GPSes, whose interface is solely USB, may have more trouble getting their GPS to work with QGIS. Your 60CSx has both USB and serial physical ports, which is a bit of a rarity. If you can't get it to work via USB, try with a serial cable (purchase separately?).

The docs for GPSBabel, manual for QGIS and your GPS manual have information on setup and connections.

Here are some sites that have additional information:

Quantum GIS – using a USB GPS device | geo.jot

GPS + QGIS. The example GARMIN 60CSX and qgis [in. 1.7.0] | Geostrona

Quantum GIS - User - Download points from Garmin GPS 60

Sometimes, the devices used in QGIS do not find the bundled 'gpsbabel' binary. Choose to 'Edit Devices..' in the GPS Tools plugin (under upload or download) and replace the '%babel' token with the actual path to the binary:

For Kyngchaos.com QGIS.app: /Applications/QGIS.app/Contents/MacOS/bin/gpsbabel
For GPSBabelFE.app install: /Applications/GPSBabelFE.app/Contents/MacOS/gpsbabel

You will probably have to set up a new device for the USB connection (see 'Quantum GIS – using a USB GPS device' above). Try setting the Port to 'usb:' as well. QGIS defaults to a serial interface, which your GPS also readily supports.

enter image description here

Connecting via serial will also let you use the Live GPS Tracking tool.

Choose the menu command View-> Live GPS Tracking

The tracking tool supposedly works with USB interfaces, but I have been unsuccessful connecting, except for serial. I believe it uses a different serial adapter package, so it's GPS support may be less than GPSBabel's.

share|improve this answer
    
Thanks dakcarto, but as for the serial interface, I don't know how my Mac can do that. I created a "Garmin USB" GPS device in GPSTools per the instructions at geo.jot, but I'm confused GPSBabel; I downloaded the app, but I still get an error message: "Could not start GPSBabel." –  Gray Shaw May 31 '12 at 23:07
    
@Gray, try switching out %babel in the config with hard-coded path of /Applications/GPSBabelFE.app/Contents/MacOS/gpsbabel which is the path to that app, if it's in your /Applications folder. The USB interface should work (eventually), but for the default go-to serial interface, you will need a Mac -> USB-to-serial adapter -> serial cable -> GPS setup. See here for examples, though you will need the serial cable for your GPS: macgpspro.com/?id=159 –  dakcarto May 31 '12 at 23:52
    
I need help with "switching out %babel in the config" - what does this mean? I understand "hard-coded path" but do not know how to execute that on a Mac. This all sounds like DOS to me. –  Gray Shaw Jun 17 '12 at 1:38
    
In the noted geo.jot site, and in your own device configurations, you can replace the %babel token with a path to a known working version of the gpsbabel binary (like the one in GPSBabelFE). Nothing DOS about this. That token is just being replaced by QGIS internally with a path, but it sometimes doesn't work. The only tokens you should not replace are the %in and %out ones, as those are replaced with values from the GPS Tools dialog. –  dakcarto Jun 17 '12 at 3:25
    
I was finally able to follow dakcarto's instructions and initiate a transfer from my GPS to QGIS. However, the transfer stopped with this message: "The layer /Users/tgrayshaw/Mapping & Surveying/SoHumMap/September2013tracks.gpx?type=waypoint is not a valid layer and can not be added to the map" - what is wrong? –  Gray Shaw Feb 18 at 0:46
add comment

The following configuration works for me with MacOS 10.6.8 QGIS 1.7.2 and the Garmin 60CSx:

Setup the 60CSx to use Garmin Serial Data Format before you connect to the computer. Press the MENU key twice to open the main menu. Use the rocker button to highlight the Setup icon and press ENTR button. Use the rocker button again to higlight the Interface icon and press ENTR button. Use the rocker button to highlight the Serial Data Format field and choose GARMIN. Press the MENU button twice to go back to the main screen.

Now connect the GPS to the computer with the USB cable.

Then open the QGIS GPS Tools Plugin. Click on the "Download from..." tab. Choose "Garmin serial" as the GPS device and "usb:" as the Port. Enter a Layer name and use the "Save As.." button to name the output file. Use the same settings in the "Upload to..." tab.

Two-way communication should work now.

share|improve this answer
    
Thanks Ravenaerie, I followed your instructions for "Download from..." but when I clicked OK I got "Could not start GPSBabel." In "Upload to...," the Data layer field does not yield any choices. Any suggestions? –  Gray Shaw May 31 '12 at 22:01
    
I can upload waypoints from my Garmin unit using GPSBabel directly and save them as a .gpx file. But when I follow your instructions for QGIS, I get "Could not start GPSBabel." Do you know why? –  Gray Shaw Jun 17 '12 at 1:44
    
That sounds like QGIS is unaware of where to find the GPSBabel program. Which path is it located on of the 2 mentioned by @dakcarto. –  wildintellect Jun 18 '12 at 16:44
    
I have GPSBabelFE and GPSBabel+ in my Applications folder. Does it matter whether GPSBabel is loaded or not? –  Gray Shaw Jun 19 '12 at 12:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.