Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have an ArcSDE error: " *Failed to connect to database. Maximum number of connections to instance exceeded "

Did what ESRI recommended :"

Check the value set for the CONNECTIONS parameter in the SERVER_CONFIG or sde_server_config ArcSDE system table to be sure it is sufficient. If it is not, increase the number of allowed connections using the sdeconfig command with the alter operation"

and still nothing works on my database server. (I can't create features, import, etc).

We use a Microsoft SQL Server. And it's an enterprise geodatabase

Thanks a lot.


Apparently it was a schema lock. I had a map service started which used that geodatabase. So how can I edit the geodatabase and have a started map service in the same time. I've already created several versions and tried to publish just the versions, but they still lock my gdb.

share|improve this question
    
1. what type of ArcSDE Geodatabase do you have? personal or Enterprise.. because of concurrent connections support change one to another. 2. What type operation handle on this sde?.. pls give some detailed information... –  Aragon May 21 '12 at 12:03
    
Wondering if you have hung connections that need to be killed? –  Chad Cooper May 21 '12 at 13:55
    
What have you increased the connection parameter to? And how many connections do you see in the SDE.PROCESS_INFORMATION table? –  Devdatta Tengshe May 22 '12 at 1:53
    
I think there were 84 connections and I've changed them to 1000. –  Ligia May 22 '12 at 8:57
    
I used :"Detach Right click DB -> Tasks -> Detach... check "Drop Connections" Ok Reattach Right click Databases -> Attach.. Add... -> select your database, and change the Attach As column to your desired database name. Ok " and I can now edit the data existing in my geodatabase, but I still cannot import other data. –  Ligia May 22 '12 at 11:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.