Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm developing a GIS app that makes use of GeoServer and GeoWebCache for serving requests, and OpenLayers for frontend. WMS requests to the GeoServer are served with no issues. But when I make a request through GeoWebCache, nothing is returned to the client. I've enabled Direct WMS Integration in GeoWebCache configuration. I'm using GeoWebCache integrated in GeoServer. My request is as shown below:

var wmslayer = new OpenLayers.Layer.WMS(
   "Kenya Administrative Boundaries",
   "http://localhost:8081/geoserver/gwc/service/wms?", 
   {layers: 'kenya_admin', format:'image/png', transparent: true},
   {opacity: 1.0, isBaseLayer: false, visibility: true}
);
map.addLayer(wmsLayer);

But the layer is not loaded. Any advice on what I may be doing wrong. Thanks in advance.

share|improve this question

migrated from stackoverflow.com May 26 '12 at 3:12

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 1 down vote accepted

My understanding of Geoserver's Geowebcache documentation is that if you enable Direct WMS Integration, you can simply point your request to the regular wms service, include "TILED=true" and Geoserver handles the rest. I.e, all you have to do is change your request to:

var wmslayer = new OpenLayers.Layer.WMS(
   "Kenya Administrative Boundaries",
   "http://localhost:8081/geoserver/wms?", 
   {layers: 'kenya_admin', format:'image/png', transparent: true, TILED: 'true'},
   {opacity: 1.0, isBaseLayer: false, visibility: true}
);

I've done that with my OpenLayers site and it works... Cheers M

share|improve this answer
    
Thanks a lot, Aragon. I'll try it out right away, and let you know my findings. –  okello May 28 '12 at 7:58
    
Aragon, it doesn't work for me. May be its a projection issue. But I'll test again later. –  okello May 28 '12 at 8:04
    
It eventually worked. Thanks a lot. –  okello Jun 5 '12 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.