Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When trying to create a topology for a polygon feature class in ArcSDE 10. I right click the feature dataset that the feature class resides and try to create a new topology. I get an error saying, "The selected feature dataset does not contain any feature classes which can participate in a topology".

The feature class I am targeting has a z value.

Would this be the culprit?

share|improve this question
add comment

3 Answers

We had a similar problem a few weeks ago - as Fezter said, you will need to unregister your dataset as versioned. The resource centre lists the steps here. A word of caution - make sure that all of your versions have been reconciled and posted against default, and not just to your QA version or anything in between. We learnt this the hard way!

share|improve this answer
add comment

I found this article on the ESRI knowledge base. You may need to unregister your feature class.

share|improve this answer
add comment

Working with topology in versioned geodatabases is relatively straightforward. But first, you need to understand some version-based workflows and the behavior of topology in a versioned environment.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.