Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, I generated a map on tilemill and exported the mbtiles file. I've setup Tilestache, and all required dependencies. I tried the OSM preview provided by default which worked fine.

When I tried to load a MBtiles file through the Tilestache config file(.cfg), the terminal doesn't show me any errors (infact it shows me all the HTTP calls perfectly fine), but the preview output at{layername}/preview.html seems to be a blank map!

When I did explicit HTTP calls to specific png images, the images are empty. In other words, I see empty outputs from it. I also tried different MBtiles files and I'm still facing the same output.

What could be the problem here??

My Tilestache config file:

    "name": "Test"
        "provider": {"name": "mbtiles", "tileset": "ward.mbtiles"},
        "preview": {"zoom": 15, "ext": "png"} 

share|improve this question

The default OSM preview page's URL is ip_address:port_number/osm/preview.html#10/37.8000/-122.2600 which indicate the zoom level is 10, so I guess you did not export mbtiles file up to that zoom level that's why TileStache generates empty page then you could manually change the zoom level and lat/lon value to force TileStache to work out preview page.

I have tested method above which shows the truth and I hope it will help you out.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.