Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I was called over to try and fix an issue with a coworkers ArcGIS software (ArcView 9.3.1 SP1, Windows 7) and couldn't fix it. When a certain layer is turned off in the table of contents it never turns off in the map. Refreshing the map doesn't work, jumping between data and layout view doesn't work either. Saving the map with the layer off, closing and then re-opening it doesn't make a difference. I removed and re-added the data, copied the shapefile to a different location, removed joins, etc. still the same problem. Has anyone had this issue and know of a fix? I don't have any control over the version and service pack they're using (they work for the state and I work at the county level, so we're on different systems). Other people in the office using the same data don't have the problem. I appreciate the help in advance.

share|improve this question
    
Group the layer - switch the group off –  Mapperz May 30 '12 at 15:52

2 Answers 2

up vote 6 down vote accepted

Perhaps the features were converted to graphics at some point. In that case, they might appear exactly the same as the original feature class but would not turn off with the feature class, since they are graphics. This is just a guess but worth a look.

share|improve this answer
    
That was a good guess! I haven't used the feature to graphics option very much, but as it turns out, it's something they use on a daily basis. They select a parcel, convert that parcel to a graphic, print a map, delete their graphic and move on. As you guessed correctly, they didn't have any parcels selected, so all the parcels were converted to graphics. I appreciate the help, thank you! –  Evan May 30 '12 at 19:00

I agree with gpeterson turn the layer off and in dataview try to click on it if it selects they are probably graphics wich might have been converted to shapefile at some time but the graphics never deleted. If that does not work. Open a blank mxd and add the shapefile from the source see if you can turn it on and off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.