Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I installed the complete opengeo-suite on Ubuntu Server and it displays that it is working fine here,

opengeo-geoserver:
  Installed: 2.5
  Candidate: 2.5
  Version table:
 *** 2.5 0
        500 http://apt.opengeo.org/ubuntu/ lucid/main amd64 Packages
        100 /var/lib/dpkg/status

But when I try to run the url (http://serverurl/geoserver/web) i am not able to get the admin page.

share|improve this question
    
use h-ttp://localhost:8080/geoserver/web –  Mapperz May 31 '12 at 20:33
    
it is on ubuntu server, i can access it only using terminal, right? so localhost won't work –  Sam007 May 31 '12 at 20:37
1  
    
Actually if I run xdg-open <url> that does it too. –  Sam007 May 31 '12 at 21:03
add comment

1 Answer

up vote 2 down vote accepted

It seems that on installing Geoserver, it is installed on port 8080. By default the apache2 server on Ubuntu Server 11.04 also runs on the same port. So this conflicts the situation and we cannot run the two different servers on the same port. Therefore,

service apache2 stop
service tomcat6 stop

tomcat6 is the server on which the Geoserver runs. After you have stopped both, you can start the tomcat6 again,

service tomcat6 start

Now you will need to reconfigure the port of apache2 by going to the DocumentRoot and changing the port to 80.

Once you have done that, restart the apache again.

service apache2 start

And you are good to go.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.