Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I load a *.csv file (delimited text) as a layer in QGIS, the scale bar shows degrees (for example 0 to 10 degrees). When I uncheck On the fly projection and change the units for feet or meters, the units changed to feet or meters but still stay to 10. My scale bar is 0 to 10 meters wich is impossible because the area covered by the points is more than a thousand kilometers... But when I use the measurements tools, the measure seems to be good. Also, when I use the buffer tool, if I write 0.15 it shows a buffer of about 10 km?

I tryed many projections type and the only one that seems to work is WGS 84 but I want something more precise like NAD 83 / Quebec Lambert because the data are in the east of Canada (In the province of Quebec).

share|improve this question

1 Answer 1

When you load CSV data (which does not contain CRS information), QGIS has to guess which CRS it could be. So it uses the default CRS (WGS84 if you haven't changed it).

The scale bar units are always same as the project CRS units. If you have layers with different CRS and/or project CRS and you turn off on-the-fly reprojection, you'll always end up with a wrong scale bar. Therefore, make sure that

  1. all layer CRS are set correctly (layer properties CRS has to be the CRS the data is actually in!),
  2. on-the-fly reprojection is on and
  3. the project CRS is a suitable CRS with unit meters.

There is no need to reproject any data permanently to solve this.


Ad buffer:

The buffer size is always in layer CRS units. It does not matter if on-the-fly reprojection is active or not!

To reproject data, go to save as and choose a target CRS. Make sure the source CRS (in layer properties) is set correctly


You might also find the explanations in this answer useful http://gis.stackexchange.com/a/27059/187 even if it's written for Argis.

share|improve this answer
    
About the scale bar... I tried with same layers CRS and same project CRS using NAD 83, NAD 83/Quebec Lambert, NAD 83/UTM zone 18N, WGS 84/UTM zone 18N...Every time, I got a wrong scale and the measurements tools shows wrong results. The on-the-fly projection is still on. I turned it off just to change the units from degrees to meters or feet. –  Parouk Jun 8 '12 at 15:34
1  
Did you correctly reproject the layer or did you just change the CRS in layer properties? The later does NOT change the geometries. It only tells QGIS to use a (most likely wrong) CRS for the layer. Exactly which CRS is your layer really in and which unit do you want in the scale bar? –  underdark Jun 8 '12 at 16:08
    
I just changed the CRS in layer properties but I'm don't know how to reproject the layer (CSV file) Is it only with save as? THe unit I want is in meter. THanks –  Parouk Jun 9 '12 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.