Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I add the following WFS address to ArcCatalog just fine and the different feature classes show up in ArcCatalog. However, when I attempt to drag or Add a feature into the TOC of ArcMap, it gives me a "This dataset appears to be invalid" error and the feature gets added to the TOC but is empty with no feature records. Could I be missing a step here? I'm using ArcGIS 10.1. Here is the WFS address:

http://ogi.state.ok.us/geoserver/wfs?service=WFS&version=1.0.0&request=GetFeature?
share|improve this question
    
I tried adding it in ArcMap 10 SP 4, and I didn't see any layers listed with the Service at that URL –  Roy Jun 8 '12 at 17:33
    
@Roy So you went into Connection Properties after right-clicking the *.fdl file under Interoperability Connections and clicked "Settings"(Parameter button in 10.1) button and don't see list of features under the Constraints>Feature Types button? –  wilbev Jun 8 '12 at 18:04
    
Sorry about that, I added it as a WMS -- I'm able to add layers from the WFS through interoperability connections. –  Roy Jun 8 '12 at 18:28
    
Yep, it can be added thru interoperability connections. So do you get the same error and empty feature class when trying to add a layer to ArcMap? –  wilbev Jun 8 '12 at 18:43
1  
I have the same problem. ArcMap 10.1 release version. @wilbev: did you find an answer? –  Claus_L Jun 21 '12 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.