Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm new to QGIS.

I created a QGIS project, loaded 1 to 3 shapefiles via Add Vector Layer (from 2008 TIGER/Line Shapefiles http://www2.census.gov/cgi-bin/shapefiles/state-files). The maps look fine and I can interact with them.

Under Layer many of the "middle" options are available after loading the shapefile, e.g., Open Attribute Table, Toggle Editing, Save as ..., Properties.

I then save the project.

After closing QGIS and re-opening the project file, all of the layer options mentioned above (and a few others) are now greyed out and unavailable.

Are these options only available right after loading a shapefile? What good is a project file if one cannot interact with data saved with the project?

And why are the Edit options always greyed out and not available?

What am I missing?

Thanks for helping me understand QGIS.

share|improve this question
1  
That's not normal behavior. One reason for editing not being available would be that a subset query has been defined on the layer. Without seeing your project it's difficult to say what's wrong in you case. –  underdark Jun 11 '12 at 6:38
    
Do you have full rights on the folders where the project file and where the shapefiles are? –  AndreJ Aug 10 '12 at 19:29

1 Answer 1

You probably just didn't activate a layer. Some entries are only available when there is a layer activated and the layer supports the operation.

share|improve this answer
    
Sorry for my denseness. What does "activate a layer" mean? Let's say I create a new project. Add a new layer from a shapefile and save the project. I can interact with the layer right after adding it. But after saving the project and re-opening, I can see the layer, but most options aren't available anymore. How do I "activate" it? –  efg2 Jun 12 '12 at 7:15
    
Click on a layer in the layer list. –  jef Jun 13 '12 at 6:03
    
Thanks for that clue, but there may be a bug. When I re-open the project, and display the layer list, the layer is selected and most of the "middle" layer options are not available. But after toggling the selection (off then back on) in the layer list the options are available -- what I was expecting. This is not at all obvious to me that re-opening a project would "look" different than when closed. Thanks for your help. –  efg2 Jun 14 '12 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.