Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I currently use Quantum GIS 1.7.4 at work and I have trouble to open Google layers extension. In fact, when I start QGIS 1.7.4 the following message appears and I cannot use Google layers extension. Would really appreciate if anyone can help me sort this problem out.

Traceback (most recent call last):

  File "C:/PROGRA~2/Quantum GIS Wroclaw/apps/qgis/./python\qgis\utils.py", line 147, in startPlugin
    plugins[packageName].initGui()
  File "C:/Users/JICA/.qgis/python/plugins\GoogleLayers\GoogleLayers.py", line 33, in initGui
    self.sessionid = gmaps.get_sessionid()
  File "C:/Users/JICA/.qgis/python/plugins\GoogleLayers\gmaps.py", line 21, in get_sessionid
    sessionid = t.strftime("%d%m%Y_%H%M%S%s")
ValueError: Invalid format string

Version de Python : 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]

Version de QGIS : 1.7.4-Wroclaw Wroclaw, 411aff6

Chemin vers Python :

['C:\\Users\\JICA\\.qgis\\python\\plugins\\GeoCoding', 'C:\\Users\\JICA\\.qgis\\python\\plugins\\elevation', 'C:/PROGRA~2/Quantum GIS Wroclaw/apps/qgis/./python', 'C:/Users/JICA/.qgis/python', 'C:/Users/JICA/.qgis/python/plugins', 'C:/PROGRA~2/Quantum GIS Wroclaw/apps/qgis/./python/plugins', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\bin\\python27.zip', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\DLLs', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\plat-win', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\lib-tk', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\qgis\\bin', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\site-packages', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\site-packages\\PIL', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\PROGRA~2\\Quantum GIS Wroclaw\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode', 'C:\\Users\\JICA\\.qgis\\python\\plugins\\fTools\\tools']

Thanks for your help.

share|improve this question
    
Google layers worked perfectly well in previous versions, much better than open layers which requires high speed internet connection. –  user10314 Sep 19 '12 at 11:08

1 Answer 1

Google Layers plugin was written by a third party and is already outdated (besides, it never worked very well).

Please use OpenLayers plugin instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.