Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I wanted to add a layer through the toolbox using arcpy. The below script works fine through the python console in ArcMap, but does not when executed through the toolbox. The layer flashes for a second in the layer management window and disappears. This looks very unlikely and I am not able to figure out how it could not work in the toolbox. Let me know if I had missed something.

import arcpy
mxd = arcpy.mapping.MapDocument("CURRENT")
df = arcpy.mapping.ListDataFrames(mxd, "*")[0]
sourceLayer = arcpy.mapping.Layer('C:/WIP/Shape files/KARTHIK.TEST_TABLE.lyr')
arcpy.mapping.AddLayer(df,sourceLayer,"TOP")
arcpy.RefreshActiveView()
share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

What version / service pack do you have? It seems this problem was fixed recently in v10 SP1.

http://forums.arcgis.com/threads/8331-AddLayer-only-temporarily-adds-the-layer-to-map

You can try downloading SP1 here. http://resources.arcgis.com/content/patches-and-service-packs?fa=viewPatch&PID=66&MetaID=1685

share|improve this answer
    
I have been working with v10. Thanks for giving me the link let me try using the service pack 1 –  Karthik Bharadwaj Jun 19 '12 at 2:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.