Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I get this error: Error 14 -- Unable to open ~/.qgis//qgis.db -- QGIS version 1.8.0-Lisboa -- Ubuntu 12.04

It was discovered when I tried to define a custom CRS and save it under: settings/custom CRS in QGIS 1.80.-Lisboa under Ubuntu 12.04 and saving the custom CRS indicated this error.

I notice that the qgis.db file is located at: /usr/share/qgis/resources/qgis.db

I created a link but this did not work either. Can I tel QGIS to look for the qgis database at the above location rather that ~/.qgis//? Looks like permissions are read and write for all users.

Thanks

share|improve this question

2 Answers 2

You can remove/rename qgis.db from/in ~/.qgis. If will be recreated automatically. The problem probably is that the format of the tbl_srs table meanwhile changed.

If you hit more problems, it might be a good idea to remove/rename the ~/.qgis directory and perhaps also ~/.config/QuantumGIS.

Beware: that will remove the old user settings, but those are probably incompatible between 1.8 and whatever you had before.

share|improve this answer
    
Dear jef. Thanks for this advice. This solved it. –  Paul Young Jun 21 '12 at 7:08
1  
Don't forget to accept his answer then. –  lynxlynxlynx Jul 9 '12 at 12:33

I suffer the same problem, but I found another solution. First, the file is in /home/vyg/.qgis and, after trying the solution above, and even change (just for trying) my distro from Ubuntu 12.04 Precise, to Linux Mint 13 (64bit), and finally to Linux Mint 13-32bit, I realize that there was a lock in the file, that indicates limited permissions. So, I simply change them with the next sequence of codes in a terminal

YOUR_USER ~ $ cd /home/MICARPETAPERSONAL YOUR_USER ~ $ sudo chmod 777 .qgis

and Listo!!! va en Español mexicano

¡Hola! Padecí el mismo problema, pero encontré otra solución. Primero, el archivo lo encontré en otra ruta /home/MICARPETAPERSONAL/.qgis, tras probar la solución que ofrecen arriba,e incluso cambiar de distro de Ubuntu 12.04 Precise, a Linux Mint 13 (64bit), y finalmente a Linux Mint 13-32bit, me dí cuenta de que la carpeta tenía un candado, lo que indica permisos limitados. Así que simplemente los cambié con la siguiente secuencia de códigos:

YOUR_USER ~ $ cd /home/vyg YOUR_USER ~ $ sudo chmod 777 .qgis

y Listo, a trabajar :-)

share|improve this answer
    
Are you sure you didn't mess up the uids while switching distributions? Sounds like the user didn't own his .qgis directory (probably his whole home directory). Did you check the actual permissions (ls -ld .qgis)? –  jef Jul 9 '12 at 14:13
    
No,that was not the case. And it was commpletly solved after the premissions were changed :-) –  user8867 Jul 13 '12 at 23:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.