Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created voronoi polygons after which I dissolved them on the basis of one attribute. Now there are cases where in for one single attribute "abc" I have3 polygons at different places with same object id. I would like to break these into 3 polygons as they are at different locations.

Is there any tool in ArcGIS Desktop or QGIS which can help me in doing that?

share|improve this question
that's indeed the problem that even when the "create multpart features" is checked on ArcGis 10 it doesn't work it never creates independent polygons. I run the dissolve tool after a union so I just wanted to "dissolve" the not fancy cliped polygons obtained while doing union but I don´t want a single row for all my polygons from one class, what I need is a single row for every independent polygon.. so I need something like from singlepart to multipart. The explode button worked well for some of them but the most difficult ones (the ones with a difficult perimeter) were not "exploded" :( help! – user21668 Sep 3 '13 at 15:32
I converted your post to a comment, @claudia, because it does not answer this question. If you would like to ask a question please consult our faq for guidance. – whuber Sep 3 '13 at 16:12
up vote 22 down vote accepted

I think that what you actually want to do is to convert multipart polygons into singlepart polygons.

In ArcGIS it can be done using Multipart To Singlepart (Data Management) tool.

share|improve this answer

In QGIS vector menu, you'll also find Multipart To Singlepart.

share|improve this answer

You should specify option SINGLE_PART when running ArcGIS Dissolve tool.

share|improve this answer
This is the best answer for preventing the problem when using ArcGIS. The Multipart To Singlepart tool (referenced by Marcin) is the best way to fix the issue after-the-fact. – user3461 Jun 21 '12 at 11:54

Another Less elegant option is to click the Explode button in Advanced Editing toolbar in Arcgis after selecting all features in Layer.

share|improve this answer

As Alex said, there is an option/check box in Arcgis 9.3 Dissolve tool, - "Create multipart features", it is "checked" as default. Hope this will help you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.