Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I created and example based off of the spherical-mercator example example and placed it here. I made the bing road layer the default. If you zoom in on a location and then switch to a google layer you'll see the map go to full extent and then zoom to the correct extent. It happens very quickly but it is a distraction. I've tried several hacks to get around this but none of them work (delayed opacity, calling setMapObjectCenter before setting visibility).

Anyone willing to figure out (or already know) how to eliminate the flicker/animation? Note that this is only an issue the first time you select a google base layer. Subsequent switching transitions beautifully.

share|improve this question
    
Works fine in Firefox 13.0.1 - no jumping to extents when changing layer. –  Mapperz Jun 25 '12 at 19:12
    
I updated to FF 13.0.1 and can witness the same flicker. Try it a second time (click Run and try a second time). –  ca0v Jun 26 '12 at 14:56
    
Submitted as issue 548 - github.com/openlayers/openlayers/issues/548 –  ca0v Jun 27 '12 at 17:09
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.