Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am following this post about how to get lat/lon information from a point file, but without success. Does this metadata posted below provide information that changes the prescribed method for getting lat/lon for each point?

In layer spatial reference system units : xMin,yMin 1091130.77,1813891.89 : xMax,yMax 1205198.85,1951669.02
Layer Spatial Reference System:
+proj=tmerc +lat_0=36.66666666666666 +lon_0=-88.33333333333333 +k=0.9999749999999999 +x_0=300000 +y_0=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=us-ft +no_defs

I have taken the following steps:

  1. Loaded a ESRI shapefile into QGIS with one polygon layer.

  2. Extracted nodes to create a point layer. Vector -> Geometry Tools -> Add/Extract Nodes. I clicked the option to create new shapfile, then clicked the option to add shapefile to the current project.

  3. Right clicked on new point layer, selected 'Save As', and specified target CRS as ESPG4326, and added GEOMETRY=AS_XY in the layer OGR Creation options. This created point layer 2.

  4. Clicked on point layer 2, then ran Vector -> Geometry Tools -> Export/Add Geometry Columns.

I ran this entire process 4 times, once with no layer OGR creation options, and once with the Geometry=AS_XY in the layer OGR creation option. I also varied step 4: once with target CRS 'layer' in step 4, once with CRS 'project' in step 4.

I also added a step 5, Right click on point layer 2, then save as CSV file.

When complete, I right click on point layer 2, click 'Open Attribute Table', and see new XY columns with numbers that are definitely not lat/lons. Also no lat/lons in the csv file.

share|improve this question
    
I know that you are trying to follow the linked post to perform this operation, but it would help if you described the process you tried, that did not work. That, along with the projection information you already provided, will help you obtain a better answer. –  Get Spatial Jun 26 '12 at 0:21
    
Thanks for the comment, I have updated to provide more detail on steps taken. –  tbone Jun 26 '12 at 12:57
    
Use some background map (e.g. a service from OpenLayers plugin) to ensure that all your reprojection steps are carried out correctly. If the numbers in the created XY columns are not valid lat/lons, something is going wrong during reprojection. –  underdark Jun 26 '12 at 13:39
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.