Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm unable to execute the routing_core.sql, receiving following error.

I'm using pgAdmin III, Windows 7, PostgreSQL 9.1, PostGIS 2.0.

ERROR: could not load library "C:/Program Files/PostgreSQL/9.1/lib/librouting.dll": %1 is not a valid Win32 application.

*** Error ***

ERROR: could not load library "C:/Program Files/PostgreSQL/9.1/lib/librouting.dll": %1 is not a valid Win32 application. SQL state: 58P01

Regards, Nas

share|improve this question
    
I am using the exact same set up and have no problem. Where did you get your binaries and .sql files from? Are you sure it is the correct version of PostgreSQL 9.1 because the one on the PgRouting site will not work with v9.1 on Windows. –  MappaGnosis Jun 27 '12 at 13:56

1 Answer 1

up vote 3 down vote accepted

Currently, pgRouting Windows binary doesn't support PostgreSQL x64(Win x86_64) version.

If you want to run pgRouting on Windows 64-bit OS, install PostgreSQL x86(Win x86_32) version.
(And PostGIS 1.5.x may be better because of assign_vertex_id - MULTILINESTRING issue.)

share|improve this answer
    
Doh! I forgot that I had installed the x32 version on my 64-bit windows 7 box for this very reason. Sorry for being misleading in my comment. –  MappaGnosis Jun 28 '12 at 8:02
    
after all, for pgRouting, i'm using PostgreSQL 8.4.4 and pgRouting 1.5. These two combinations work perfect. ;) –  nasrulhazim Sep 20 '12 at 8:55
    
sorry for the super late response. ;) –  nasrulhazim Sep 20 '12 at 8:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.