Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to QGIS and am probably missing something but when I set up a new composer and add a map to the page nothing appears. I have pressed the render button and the up date with no results. When I print the map there is no map but the legend I added to the page is there. Any help would be appreciated. I am using the latest version of GGIS on a MAC running Lion.


share|improve this question
Have you checked that the extents are set correctly? Is the preview set to "Render" instead of "Rectangle"? – underdark Jun 27 '12 at 17:36
Hi Thanks for getting back to me, I have set the preview to Render and checked the Set To Map Canvas Extent button, the coordinates look correct for my map and when I hit the update preview button -- no change, still a blank on the composer. – Andy Jun 30 '12 at 23:02
Ok after much playing around I find that I can display a map in the composer with data from an imported text file but not with a shape file?? HELP – Andy Jul 1 '12 at 17:41
Sorry but I've made hundreds of maps from Shapefiles and never met any such problem. Might well be Mac specific. Have you tried asking on the mailing list yet? – underdark Jul 1 '12 at 17:47
Andy, can you please update me on what you did to solve your problem? I've looked everywhere and you are the only person I've found that has figured it out. – JHT Apr 11 '13 at 20:20

I was running into this problem as well and the following worked for me:

Click "Add map" from the left hand side, then draw a rectangle on the canvas, and voila! so appears your map.

Hopefully this works for everyone else that is new to this.

share|improve this answer
Welcome to! I think you'll find that the original poster did this step already ('add a map to the page') but found it wasn't rendering; that would have been QGIS 1.7 which had a lot of bugs. – Simbamangu May 31 '14 at 12:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.