Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am new to QGIS and have just installed 1.8.0 on a Gateway laptop that is about 2 years old. It is running Windows 7, has an Intel Core i3 2.13 GHz processor, 4 GB of RAM.

I've just brought in my first layers (235 MB of data in 3 shapefiles) to my first project, and it takes forever to render. By forever I mean more than one minute for each task: zoom, move, rectangle select, changing the order of layers.

The data is PLSS data from the state of Oregon as provided through the federal government through BLM. Although I downloaded only the Oregon data, when I right-click on the twnshp layer onto attribute table, I do see records relating to CA and ID as well as Oregon.

Will I not be able to run QGIS on this computer?

Thanks so much, Yeye

share|improve this question
1  
Which version of QGIS did you install? How big is the data file (MB, no. features)? –  underdark Jun 27 '12 at 20:28
2  
Might be worth giving this question a little bit more informative title.. –  radek Jun 27 '12 at 21:00
    
underdark I installed 1.8.0 Lisboa. –  Yeye Jun 27 '12 at 21:13
    
Its going to be easier if you answer all questions instead of half of them. –  underdark Jun 27 '12 at 21:16
    
It looks like I have added about 235 MB of data in 3 layers. All three are shp files so far. Did I answer how many features? I don't know the language yet. –  Yeye Jun 27 '12 at 21:23
add comment

2 Answers

I've run QGIS on machines older than that.

You could try filtering the results to the state. Right-click on the layer entry, and choose "Query". You can then filter to the state of interest.

Keep in mind that, depending on which PLSS dataset you're dealing with, it can be a lot of lines to render, especially if your data goes down to the quarter-quarter section level.

share|improve this answer
    
Thanks very much f00b, I think it does go down to the quarter quarter section level. Good to know it's likely not the computer. I will try filtering. –  Yeye Jun 27 '12 at 20:25
add comment

235 MB are a lot of data to render, especially if you are zoomed out to full extent. Zoom in and it should be faster. Loading the data into PostGIS and adding a spatial index will also speed up rendering when zoomed in.

If you are doing a series of changes, you might want to turn rendering off for while (bottom right corner).

In Settings, there is also an option to enable "render caching". It avoids unnecessary redraws.

Do you really need to have all data loaded at once? If you are just working in a subregion, take the time to extract it from the bigger files.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.