Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I created a GeoTiff raster in python, that is projected with the following CRS: *"+proj=merc +lon_0=34.9586601257 +k=1 +x_0=-0 +y_0=1453756.01544 +a=6370997 +b=6370997 +units=m +no_defs"*

When I load it in QGIS, I set project CRS from layer and enable on the fly CRS transformation. Then I open a shapefile of the country (Tanzania), but it doesn't overlap, even if I set the same CRS manually. I'm sure that the raster extent is correct. It looks that it is a problem from the shp. Here is a sceenshot: http://imageshack.us/f/193/wrongrastersinqgis.jpg/ It is working if I georeference my raster with decimal degrees WGS84... But not if I use the projection coordinates. That is strange. Screenshot: http://img841.imageshack.us/img841/9500/rastersinqgis.jpg

I did the same with another raster I also created in python, that is projected with: *"+proj=lcc +lat_1=51.4259986877 +lat_2=51.4259986877 +lat_0=51.5159492493 +lon_0=2.60400009155 +x_0=163358.880084 +y_0=163358.804499 +ellps=WGS84 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs"* And with this raster, I can properly overlap the shapefile of the country!

I don't understand why it is working with a CRS in lambert and not with a CRS in mercator.

Any idea?

share|improve this question
    
If you could offer a picture, with illustrations of the magnitude of the mis-alignment, it would be helpful. –  MappingTomorrow Jun 29 '12 at 15:00
    
I added links to screenshots. Thanks :) –  Greg Jun 29 '12 at 15:23
add comment

1 Answer

Sorry, very late answer!

It looks like there is a strictly east-west offset to the data. Could the lon_0 (central meridian) parameter be incorrect? Or you used x_0 (false easting) in the Lambert conformal conic case, perhaps you should use it for the Mercator case too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.