Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I lost selection and navigation tools from the GGIS 1.8 toolbar when I tried drag then to different place. I can't get them back anymore. Where they disappear? All these tools are checked but are still missing.

share|improve this question
What platform are you using? – dakcarto Jul 3 '12 at 14:42
Thanks Alex! Toolbars are back. – user8628 Jul 4 '12 at 7:40

Toolbars are located outside your screen area.

You can use Python console to move them on screen.

Here is example of moving Navigation Toolbar:


Names of other toolbars can be found by this link.

share|improve this answer
I had the same problem but with the advance digitizing one. Thanks to this I've got it back. Cheers! – Matt T Nov 29 '12 at 13:51

A simple work-around is to change your screen to a lower resolution, drag the "missing" toolbar in position and switch back to the resolution of your choice. Works fine on Mac/Apple platforms.

share|improve this answer

uninstall, clean registry with ccleaner.remove .qgis folder ( note the dot) reinstall.

share|improve this answer
No need to uninstall. Just delete the registry key HKEY_CURRENT_USER\Software\QuantumGIS\QGIS\UI – Nathan W Jul 4 '12 at 0:35
Nathan - I can't seem to get this working. Do you just remove the .qgis folder and then delete the UI key and then restart QGIS? – Matt T Sep 25 '12 at 13:51
Thanks Nathan, the Python console didn't work for me but your suggestion worked. – Freeze Jan 14 '14 at 11:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.