Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a geotiff file in UTM and units in meters. I used gdal_translate with this command :

gdal_translate -of GTiff -a_nodata 0 -a_srs EPSG:4326 old.tif new.tif

gdalinfo on new.tif shows that the file units are in degrees while the data (corners,origin ...etc) are given in meters which is wrong. Is it possible to reverse/correct this action (on the new file) so I can get the file with either UTM in meters or go on and make the file in "real" degrees because I deleted the original file?

Thanks.

share|improve this question

2 Answers 2

Praobably what you want is gdalwarp. It is the right tool to make projection transforms, indicating the source (s_srs) and the target (t_srs) CRS. The a_srs option in gdal_translate overrides the Geotiff projection, it doesn't transform it.

share|improve this answer

You seem to be getting confused between a geographic coordinate system, which is what EPSG:4326 represents, and a projected coordinate system. Looking at this answer might help.

To recover the right projection parameters in this case, you need to know which zone your data is in, then use the -a_srs parameter with either EPSG:327xx for the southern hemisphere or EPSG:326xx for the northern hemisphere, where xx is the UTM zone.

share|improve this answer
    
Thanks. It works. I should have used gdalwrap instead. –  alsaleem Jul 13 '12 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.