Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

From other posts I worked out how to activate the "move label" icon and was successfully able to move a number of labels into the positions I wanted. However when I untoggle the "edit" function for the vector file concerned the labels that I have just moved all disappear - leaving me with only the unmoved labels.

I cannot find anyway to bring them back. How do I stop the moved labels from disappearing?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

The coordinates of moved labels are stored in the attribute table. It could be that the coordinates are truncated when they are permanently saved. Check before and after toggling "edit" to see if this is the cause.

share|improve this answer
1  
Yes, that's exactly what's happening. I'm a bit new to all of this - and in adding the dummy X and Y fields to the vector file I set it ti "text string" and length of 4 (thinking this would cover the words "NULL"). Now I see how it works. So it seems OK now that I've redone it and set a length of 10. However i'm also wondering if I should've set it to decimal rather than text? –  AndrewO-S Jul 19 '12 at 10:34
    
I'd definitely recommend decimal. (Please accept the answer if your problem is solved.) –  underdark Jul 19 '12 at 15:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.