Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I export my map from Print Composer in QGIS 1.7.4, an odd red band appears across the middle of the image. This happens when I export to both PNG and PDF. Its not visible on the screen before export, or present in the original raster image.Images showing red band across the middle The band is to the left of the island halfway down the coast, below Pwani.

Any ideas what's causing this and how to fix it?

share|improve this question
1  
Can you tell us a bit more about the source data? Is it possible you have two maps that overlap in that location? –  BradHards Jul 19 '12 at 11:27
2  
It looks like the same bug logged in the answer here: gis.stackexchange.com/questions/8572/… –  andytilia Jul 19 '12 at 13:27
    
The base images is from NASA's Blue Marble, and is a single image. –  gisol Jul 20 '12 at 10:04
add comment

3 Answers 3

up vote 4 down vote accepted

I had a similar problem with a composition, although my banding wasn't nearly as wide as yours appears to be. My banding was more of a streaking and was only in the output and not apparent on the screen.

I was able to correct for my problem by down sampling the quality (resolution) of my composition to 300 dpi (more than adequate for 24" x 36" output) in the composer > general settings. I haven't had a problem since and have concluded that a higher resolution setting might have exceeded my computers capability?

settings

share|improve this answer
    
I'll try this too, thanks. Will post results when I do. –  gisol Jul 20 '12 at 10:05
4  
Changing the DPI from 300 to 200 or 250 removed the band, but changing up from 300 to 400/500/600 did not. –  gisol Jul 26 '12 at 15:31
    
+ 1, apparently will be sorted when 1.9 is released or if you go to trunk. hub.qgis.org/issues/5133 –  Willy Aug 20 '12 at 10:38
add comment

This seems to happen when you use a semi-transparent raster layer. Look at this

QGIS composer - How can I eliminate striping across transparent raster layers?

which describes exactly the same problem. It seems to be a bug, and as far as I know It has not been solved in 1.8 (tried in ubuntu and win7). So, the solution, is avoiding the use of semi-transparent raster in your composition. If you have a shaded relief model with no transparency, everything should be fine, no striping.

share|improve this answer
1  
Yes, now you mention it, I think this happened after I made the base image a little transparent to lighten it. –  gisol Jul 20 '12 at 10:05
add comment

I also think it is a bug. For me it happens in QGIS 1.8.0 exactly everytime on the middle line of the page.

Here's how I circumvent the bug:

  • open the PDF export in Illustrator
  • Object > Reduce Transparency > Fine
  • alternatively one can crop one of the two overlapping layers to avoid overlapping.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.