Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I used modelbuilder, and the last step is to collect feature classes after iteration results to geodatabase using conversion tools of feature class to geodatabase(multiple). However, I met an error: ERROR 000210: Cannot create output. How can I deal with that?

I also found some discussions in ESRI forum and StackExchange, but still I can not find the answer which works for me.

http://forums.esri.com/Thread.asp?c=93&f=1728&t=279556

http://forums.esri.com/Thread.asp?c=93&f=985&t=266871

Trouble importing Feature Classes into Feature Datasets

Thanks in advance!

share|improve this question
1  
Do you have permissions to write to that location? Try writing to your desktop instead and see if that fixes it. There could also be a lock on the current feature class you're attempting to write to. –  nagytech Jul 23 '12 at 22:10
    
When you get a chance would you perhaps be able to tidy up your question and provide it with a separate answer (it is OK to answer your own question) so that your learnings may be shared, please? –  PolyGeo Jul 24 '12 at 0:50
    
@Geoist Thanks for your suggestions –  Vicky Jul 24 '12 at 2:19
    
@PolyGeo I can not post my answer below right now, so I add in the question. –  Vicky Jul 24 '12 at 2:19
    
@VickyYan-tingLiau You were either viewing a layer you were attempting to write to, or you terminated a script before python could release the lock. –  nagytech Jul 24 '12 at 3:03

1 Answer 1

up vote 1 down vote accepted

Finally, I set a new geodatabase to save these files, and the problem was solved, but I still do not know why the files are locked. I set all file results in the same geodatabase with different names. This situation is different from the last link pointed out.

Based on ArcGIS 10 help, here is the description of 000210 : Cannot create output

Description The output cannot be created. Potential reasons include data locking, an incorrect path, and limited access rights. Solution Confirm that the data is not locked by another user or application and that you have full rights to the workspace being used. Check to make sure that the path to the data is correct (check for typos in the folder path). Try creating the output in a new location.

(http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//00vp0000000n000210.htm)

At least, it works for me to save in another location.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.