Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When i check to label polygon feature, one out of a total five polygons shows like 10 labels on top of it. That particular polygon is only one polygon, represented by one row in the table, so i dont see why it shows 10 labels on top of it.....?

I havent selected any advanced label options, that could have maybe created a conflict.

Any idea anyone?

I know that in ArcGIS there is an option; show only one label per feature - BUT there no setting like that in qgis, that i have found.

a screen of the problem

enter image description here

share|improve this question
    
That shouldn't happen, QGIS will only label a feature with one label. Can you provide an example data set? –  Nathan W Jul 30 '12 at 9:47
    
Can you make a screenshot of a) the labeled polygon b) the label menue with your settings pls? Would be easier to help then I think. –  Shepherdjo Jul 30 '12 at 9:48
add comment

1 Answer 1

If you use new labeling (from labeling toolbar) instead of the old version (in layer properties), the problem should go away.

The new version actually has an option called "label every part of multi-part feature" which should be similar to what Arcgis offers.

share|improve this answer
    
Alrighty - thanx it worked fine using the new tool. The old one kept giving me that problem. Tanks for the fast response!!! –  user9200 Jul 30 '12 at 12:20
    
@user9200: Glad it worked. The best thanks is to upvote and accept the answer. –  underdark Jul 30 '12 at 13:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.