Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have an app based on leaflet 0.3.1 and it is time to upgrade to 0.4 !!! Nice ! So, what to do now !

Obviously, our map is absent in the browser, so let's have a look inside our files. Well, i have changed the scripts url in html to their new path...no more append on the screen...Héhéhé, of course is not so simple :D

Right, so now, let's start by the map and one of those layers... I have seen the document of reference : https://github.com/CloudMade/Leaflet/blob/master/CHANGELOG.md#other-breaking-api-changes

but i don't know how to start, is that to remove all the new ? thanks if you can help from that point !

Edit: After one hour, i get my geojson back ! but with a bit of pain ! let's continue if it's all ! one good sign is that i have no error in CSS also :P

share|improve this question
    
After 2 days, i'm still implementing the last 0.4 !!! with a lot...of pain, i would say...but still in progreee ! –  Kolam - urielDev Aug 1 '12 at 13:40

1 Answer 1

You don't have to switch to new syntax without "new", the only two major things to update are GeoJSON and custom icons (if you have any).

Let me know if you have any other trouble.

share|improve this answer
    
Hi, i get it out !!! ouf! it works even better in term of speed !!! but i asking myself about the next one... It was a pain to check all layers even with firebug and FF devbar...anyway, thanks. –  Kolam - urielDev Aug 7 '12 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.