Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I can't add JPG files into QuantumGIS. I get an error message "C:\Spatial_Days\Data\Working\AP_Coast_Export.jpg is not a supported raster data source".

I am using QGIS 1.7.4 Wroclaw with GDAL 1.8.1 installed from OSGEO4W.

Any ideas? Are som JPG libraries in the wrong place?

Regards Richard

share|improve this question
    
Can you start the OSGeo command line, and run gdalinfo --formats? In the list that is returned, check for JPEG. i.e. C:\>gdalinfo --formats | find "JPEG". –  Micha Aug 11 '12 at 10:59
2  
Updating to qgis 1.8/gdal 1.9 is also suggested. In QGIS 1.8 you can also see the supported raster formats in the settings->options->gdal menu. –  Giovanni Manghi Aug 11 '12 at 15:18
    
I'd also test the error by trying to open another JPEG to see if it is all JEPG files or just that one. If you can open other JPEGs I'd assume that your build is OK and that the problem lies with this particular file. You may want to check that it is not open in some other program, especially if you had just created it with the gdal command line utilities. You can also check the file itself by opening it with GIMP. If GIMP fails, too the chances are that your file is corrupt. –  MappaGnosis Aug 13 '12 at 13:02
    
Hi guys, used C:\>gdalinfo --formats and JPEG is on the list. Tried many JPEG's and even TIFF's and get the same message. One issue is I noticed there are 4 gdal dirs in c:\osgeo4w\apps namely gdal, gdal-16, gdal-17 and gdal-dev. Is that an issue? It reallt seems like it can't find the raster libraries and thus sees them as unsupported? –  Richard Oates Aug 15 '12 at 11:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.