Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I need to add stores (shapefiles) to geoserver running on localhost:8080. In data_dir/data I have directories containing shapefiles. I add them as workspaces with Namespace URI set to localhost:8080/geoserver/data/*name_of_the_dir*/.

When I try to add new store, the URL field in Connection Parameters doesn't open though and I can't choose which shapefile I want to add. I suppose the only error might be in localhost:8080/geoserver/data/*name_of_the_dir*/. I tried many different variations of this path, none of them worked for me.

So the question is rather simple (hope the answer too): How do I add a store to a workspace when working in localhost? Thanks for any help.

PS: The geoserver I'm working on is meant to run offline, thus I can't enter web URLs in Namespace URI.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The Namespace URI can be any value you want provided that it is unique (at least) for your install.

The URL field in the Store tab is the path to the shapefile you are trying to load - it has nothing to do with the Workspace URI. The easiest way to fill it is to use the browse button and navigate to the file of interest. Or you can enter a relative (to the GeoServer data dir) or absolute path to the shapefile - including the file.shp part.

share|improve this answer
    
That's the problem, I don't get the browse button. I do when using the geoserver we run online, but with the one for offline use, the browser button is just no there. –  zimmi Aug 13 '12 at 11:11
    
just use name_of_the_dir then –  iant Aug 13 '12 at 11:18
    
Yes, that works. What I just found is the button is missing in Coordinate Reference Systems dialogue of the layer as well. Thus I can't choose the crs of a shapefile (nor enter it manually, as the input field is protected). What can be causing this problem? –  zimmi Aug 13 '12 at 11:26
    
Sounds like your install of GeoServer is broken somehow, try reinstalling it –  iant Aug 13 '12 at 11:29
    
The button is visible with the clean installation, I get nullpointerexception when selecting declared crs though. Gonna try another version. Thank you anyway. –  zimmi Aug 13 '12 at 12:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.