Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Has anyone tried to deploy the ArcMap add-in for both ArcGIS 10.0 and ArcGIS 10.1? There is a target version parameter in the add-in config XML file that needs to be specified. After upgrading the code to VB MS VisualStudio 2010 and ArcObjects 10.1 it can no longer be used in ArcGIS 10.0. What are your strategies for upgrading your add-ins from ArcGIS 10.0 to 10.1 while maintaining the compatibility with 10.0?

share|improve this question
    
I would be somewhat surprised if add-ins developed for 10.0 don't work in 10.1. Is that the case? –  blah238 Aug 29 '12 at 17:21

1 Answer 1

up vote 3 down vote accepted

With previous versions of ArcMap (9.x) you needed to compile for the lowest common denominator. For example a COM extension written for 9.2 would install in 9.3 as long as any newly added or depreceated ArcObjects were not used. The service pack also made a difference. An extension written for 9.2 SP4 would not install on a 9.2 SP1 machine. However the reverse would work.

Regarding Add-ins in 10.x, I have not tried to install my 10.0 Add-ins in 10.1. I expect the same behavior though. If you need to deploy in both environments then compile the Add-in on a 10.0 developer machine and it should deploy in 10.1. I would contact Esri if this was not the case as it would be a major problem for many users.

If you want to use 10.1 on your dev machine than see this thread:

Can AddIn target somehow set to be 10.x

share|improve this answer
    
Thanks. This answers all my doubts and questions. –  jan_b Sep 7 '12 at 10:39
    
Also discussed here –  Barbarossa Jun 30 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.