Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I just have an annoying problem with the Field Calculator in ArcGIS 10. I selected specific points of a Shapefile I want to calculate, but FC is always calculating all fields. Unfortunately there is no checkbox in ArcGIS 10 anymore to tell FC to only calculate selected fields.

I discovered that it seems to be a problem with the Attribute Table since values can only be changed manually while being in the "Show selected records" mode. Otherwise my edits won't be even recognized (even acutal typed in ones).

I tried both activated Editor and not activated Editor for FC. Just a few minutes ago everything worked out fine, now all Shapefiles can't be calculated according to the selection anymore. :/

Anyone an idea what went wrong? I'm not aware of having changed any settings. Restart of ArcMap also doesn't do it.

share|improve this question
    
I found the opposite to be the case. I'd inadvertantly left one record selected and couldn't figure out why my field calc operation wasn't running on all fields. gis.stackexchange.com/questions/29235/… –  Roy Aug 30 '12 at 12:09
    
It seems not to be a selection problem. No matter how many fields are selected (or none) all fields are always being calculated (or better say: filled). Could it be a bug? –  basto Aug 30 '12 at 12:35
2  
Several times you've mentioned selected fields when I think you must be meaning selected features because the Field Calculator only works on one field at a time. –  PolyGeo Aug 30 '12 at 13:04
1  
ah yes, I'm sorry for this. Of course I mean selected features. –  basto Aug 30 '12 at 13:20
    
What service pack are you using? –  Get Spatial Aug 30 '12 at 15:10
show 3 more comments

2 Answers

up vote 2 down vote accepted

I found that field calculator does funny things when feature class is outside spatial (!) extent. Felix

share|improve this answer
add comment

We have a similar problem at least with ArcMap 10 SP5.

If we join two tables Field Calculator is always calculating the values for all features - even if we select only some features.

If we have no tables joined Field Calculator behaves as expected. Only the selected features are updated with new values.

I think this is a serious bug.

share|improve this answer
    
Thank you for this comment! This sounds similar to my problem. How about if you create a new Shape File from your joined tables (if you have spatial reference) and calculate then? I geocoded an Excel table which resulted in a Point Shape File of course, where the Field Calculator problem (still) occurred. Only restart of ArcMap and Import of the Shape Files into a new MXD file does the trick. –  basto Sep 5 '12 at 11:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.