Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am Running QGIS Lisboa 1.8.0 on a MacBook Pro. I have several vector layers with similar information which clutter the Layers panel. I created a group to put them in but when I drag and drop the layers into the new group I get just so many into the new group and then the layers panel becomes unstable. I can start to drag another layer and the new group disappears. QGIS then exits generating a large error report. I am using the method given in the manual for QGIS 1.7.0 and it appears to work up to the point where it all goes wrong.

Is this a known problem with this version of QGIS? I havent been able to find a reference to this particular problem.


share|improve this question
At what count is the tiping point? – lynxlynxlynx Aug 30 '12 at 19:17
I can get 8 layers in to the new group. When I try to drag the last layer in the new group disappears and I get an error message std::bad-alloc with an OK option. At this point the new group and the last layer have disappeared from the layers pane. When I click OK I get the spinning rainbow of death and QGIS quits and a very large 'problem Report is generated. I saved the project with the new group with the eight layers in it before I tried to drag the last layer in. Now when I reopen the project the new group and contents is no longer in the layers pane. – nigellaw Aug 30 '12 at 20:07
I could not reproduce the error on Windows XP, Qgis 1.8.0 and master. – AndreJ Aug 31 '12 at 5:34
up vote 1 down vote accepted

This is definitely a bug. There are already a few known similar cases, but you describe something new, so please report it on the bugtracker (include the generated report). For reference, the most similar existing reported issue is this one.

share|improve this answer
I have tried to re-create the original problem but without success. I can't get QGIS to crash. I did manage to create a new group and drag and drop the new layers to it as I created them. However when I save the project, quit QGIS and then reopened QGIS and the project, the previously created group and it's contents were not there. I will tru again to re-create the problem and report back. – nigellaw Sep 2 '12 at 18:30
OK, tried again. Still can't get QGIS to crash. Re-imported all 8 new vector layers. Created new group and dragged new layers into it. Added some labelling to a couple of the layers (as I had in original scenario). Saved the project, quit QGIS and restarted again. Opened project and all the data is there. There is something more subtle going on here but I can't get to it :( Good that QGIS is performing as it should but annoying that intermittent problem exists. – nigellaw Sep 2 '12 at 19:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.