Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've been using OSM2PO and it's a great system so far.

However, in version 4.5.2, I can't seem to ignore the one-way restrictions for calculating walk distances.

In the browser version, I check on "Ignore Restrictions" and "Ignore OneWays", but it makes no difference and still obeys the one ways, creating a longer/further walk time than is necessary.

I have tried various settings in the config file, such as these, but they don't seem to help:

graph.build.excludeWrongWays = true
graph.support.segments = true
graph.support.edgeflags = true
graph.support.reverse = false

Am I missing some kind of setting that disables oneways? Could I have done something in the build phase which would have prevented this?

Thanks for your help!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

graph.build.excludeWrongWays should be set to "false" in order to route (include) "wrongWays" (=reverse oneways) The parameter effects the build phase and is some kind of compression. Compare the sizes of the generated graph(gph)-files when set to true or false. At runtime the DefaultRouter and most of the other experimental routers in osm2po take this into account. If they don't, then there is sth. wrong.

share|improve this answer
    
Thanks! This worked after rebuilding the graph. –  DFx Sep 1 '12 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.