Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am migrating my Application built in Version 9.3.1 to version 10 In my code I am getting execption:

{"Retrieving the COM class factory for component with CLSID {4147A362-EFC4-11D3-
 A0A4-00C04F6BC626} failed due to the following error: 80040111."}

at this place

IExportOperation pExportOp = new ExportOperationClass();

I have alreday bind my application with bindmanager code

ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.Engine);

Every thing works fine like creating IWorkspaceFactory InitiallizeLicense, exception arise as this statment is executed.

IExportOperation pExportOp = new ExportOperationClass();

I found at google that beside binding , some times we have to use

ESRI.ArcGIS.VersionManager.LoadVersion(ESRI.ArcGIS.ProductCode.Engine, "10.0");

but I am not able to access ESRI.ArcGIS.VersionManager

Is there any solution to avoid exception.

Please help.

Thanks

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.