Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm unable to install QGIS on lubuntu (LXDE desktop). This is what it says on the terminal:

Package qgis is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'qgis' has no installation candidate

On previous attempt of installation the problem was in absence(?) of QT environment (if I understood correctly).

share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

Im not sure about your distro, but on Ubuntu, you have to edit /etc/apt/sources.list file and add the qgis repository at the end (this is for 12.04 Precise):

deb     http://qgis.org/debian precise main
deb-src http://qgis.org/debian precise main

Then also add the public key through the terminal:

gpg --keyserver keyserver.ubuntu.com --recv 997D3880
gpg --export --armor 997D3880 | sudo apt-key add -

Then type

apt-get update

to refresh the packages list, and then you should be able to do: apt-get install qgis

Note: some of the commands may require root privileges (using sudo in front)

share|improve this answer
    
Thanks!It worked perfectly! –  Zoran Sep 7 '12 at 16:03
    
@Zoran It would be helpful if you would accept this as an answer by clicking on the checkmark. I usually always upvote the answer first by clicking on the up arrow, then on the checkmark. –  Rayner Oct 7 '12 at 9:31
    
@Zoran Please accept the answer so this question can be marked as closed –  underdark Oct 7 '12 at 9:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.