Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I enable GRASS plugin in QGIS (Plugins -> Manage Plugins -> GRASS), I got a message: Exception - G_getenv(): Variable GISDBASE not set.
I googled and found some information here but don't know how to "unset GISRC".
Anyone please show me how to do it?

share|improve this question
up vote 3 down vote accepted

I solved it. I don't know if every step below is necessary but here's what I've done:

  • Open the terminal and run GRASS from it.
  • Create new Location and Mapset
  • Import some data, save and quit.

Now I can open QGIS and enable GRASS plugin with no problem.

share|improve this answer
If you could mark your answer as solved that would help other users as well – nickves Sep 10 '12 at 11:52

Another option is to unset GISRC

In order to do so: Go to Computer>System Properties>Advanced System Settings>Advanced>Environment Variables >>> delete the GISRC variable

share|improve this answer
Your answer is for Windows systems while my question is about Linux. May be it will be of help to those who use Windows. Thanks anyway! :) – Cao Minh Tu Oct 10 '13 at 1:50
Sorrry I didn't read carefully and missed that it is about Linux. But I guess Windows user have the same problem... – ustroetz Oct 10 '13 at 16:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.