Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have been trying to set up SAGA to work using Sextante in QGIS. I have followed the instructions to configure SAGA in Sextante, with the following input in the path for the SAGA folder C:\Program Files\SAGA-GIS\saga_gui.

When I then try to use a SAGA algorithm I get this message:Saga folder is not configured. Please configure it before running SAGA algorithms.

When I go back to the Sextante configuration options, the path for the Saga folder is empty. There is no information under the Sextante history log.

Anyone got any ideas about how I can resolve this issue?

share|improve this question

1 Answer 1

I have it configured and working well with QGIS 1.8. I decided to have SAGA in a folder without spaces. ( not sure if that affects function). Configuration screenshot attached. enter image description here

share|improve this answer
    
Thanks for the reply Erick. I've just tried setting it up on my home computer, with QGIS installed through OSGeo4W and SAGA in the apps folder as you have it set up, but still the same problem? Not sure what you mean by a folder without spaces? –  Bob Thomas Sep 11 '12 at 20:52
    
He means a path (to SAGA binaries) with no spaces in it. Are you sure you are pointing to the right binaries folder? Try download the "msw" SAGA package, it does not need any installation, just unzip. –  Giovanni Manghi Sep 11 '12 at 21:02
    
I have downloaded the msw SAGA package and located it as in Erick's configuration. Still the same issue, I set the SAGA folder, close the dialogue box, try to use a SAGA module, and get the error message. I am having this issue using a computer at home and at work? –  Bob Thomas Sep 11 '12 at 21:37
    
@BobThomas. Maybe an uninstall and re-install of the Sextante plugin (1.0.7) might help. –  Erick Sep 12 '12 at 8:52
    
OK, now I feel like an idiot. I've just realised I have been copying the file path over the SAGA folder text in Sextante Options rather than into the box to the right of the text. I've got it working now. Doh :) Thanks for your help. –  Bob Thomas Sep 12 '12 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.