Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

im working on Ubuntu 12.04 server; i noticed this when i installed additional support for ECW format into the GDAL 1.9.1 which worked ok. Then i tried to add ECW files to Qgis but it said they still weren't supported. I checked Help->About and to my surprise the gdal version that qgis was using was 1.7.3; no wonder they didnt work.

Through trial and error i removed Qgis then i reinstalled it via synaptic installer and also forcefully disabled the libgdal 1.7 as a dependancy. Then qgis loaded the version of GDAL i intended for qgis from the beginning. But this seems like an overkill to do and i dont feel like im having much control here

Is there a better way to for example:

  • check which dependancies exist and dont need installing, or
  • is there a way, a config file or something to tell qgis which library version you want it to use

The packages for 12.04 seem to be quite old and have old dependacies installed with them. This same issue arises with qgis-mapserver for which i have no way of telling which version of gdal it is using, but my guess is the old one, because ECW imagery doesnt work while other does.


share|improve this question
up vote 7 down vote accepted

If I had to guess you are not using the most uptodate QGIS. please follow this link, to ubuntuGIS repository and they have instructions on how to include them in your software sources.

I believe this is the recommended method of using OSGeo projects in Ubuntu hope this helps :)

ps: you can also just cmdline:

sudo add-apt-repository</code>

PSS: this is similar question: How to install stable GDAL on Ubuntu 11.10?

EDIT: found another link: How can I install gdal 1.9.0 on my linux ubuntu server 10.04

share|improve this answer
This is the right suggestion, use always the ubuntugis repo, because it has all the packages and the latest version of them. In the standard Ubuntu repos for example there is a not recent version of GDAL. The QGIS project maintain a repo with qgis compiled against the packages available in the standard Ubuntu repositories, so sometimes it is easy to make confusion. – Giovanni Manghi Sep 11 '12 at 21:20
I would suggest ubuntugis-unstable which contains more recent releases of gdal qgis and postgis $ sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable – nickves Sep 11 '12 at 22:15
Okay.... i ll build a virtual machine from scratch and start over, because im quite sure i actually used this repository for my qgis installation at some point. Thanks for the tips anyway – U2ros Sep 12 '12 at 8:04
Indeed you 2 are right. The installation listed on official page install outdated libraries with qgis(and i recommended this to some guy just a few days ago :D) Btw, does anyone know why is there a library called libgdal-1.7.0 listed as a dependancy. This probably isnt gdal itself is it? – U2ros Sep 12 '12 at 9:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.