Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am with ubuntu 12 and Qgis 1.8. I have installed QGIS and grass plugin but I can't install python plugin. How to install python plugin with dependeny in Ubuntu?

~$ sudo apt-get install python-qgis
[sudo] password for sugandha: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-qgis : Depends: python-qt4 (>= 4.1.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
I think this might be because not all of the packages requested are present in the repository. It's happened to me using the package manager, if you wait a day and then try again you might have better luck. N. –  nhopton Sep 12 '12 at 10:18
    
@nhopton its 4th day :( already tried installing dependency it asks for another dependency in chain... –  kinkajou Sep 12 '12 at 10:34
    
Then I'm stuck I'm afraid. If you try installing QGIS using the package manager do you get the 'Partial Download' warning? –  nhopton Sep 12 '12 at 11:25
    
Hi, are you using the ubuntugis repository? check here for a similar problem and how to add a new repository: gis.stackexchange.com/questions/33252/… –  s_a Sep 12 '12 at 13:05
    
just a thought: have you tried <code>sudo apt-get build-dep python-qgis</code> ??? –  s_a Sep 12 '12 at 13:21
show 2 more comments

1 Answer

Which repository are you using? You might want to add the following to you /etc/apt/sources.list

deb http://qgis.org/debian-nightly precise main
deb-src http://qgis.org/debian-nightly precise main

After that, update your system

apt-get update

Next, add the qgis public key to our package manager's key ring

gpg –keyserver keyserver.ubuntu.com –recv 1F9ADD375CA44993
gpg –export –armor 1F9ADD375CA44993 | sudo apt-key add -

Then try installing again.

sudo apt-get install python-qgis 

source: http://blog.gambliser.com/2012/06/how-to-install-quantum-gis-on-ubuntu-12-04-precise-pangolin/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.