Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a problem to display elevation data with pseudocolours. The channel 1 is from -3.40282e+38 to 149.717 . A colleague used 1.7. and it looks like it should (from blue to Red) when I use QGis 1.8 the complete raster is red with an unreasonable classified legend with four colours (three with minus values, one with maximum value red) any ideas? Bug, hidden button, secret?

Thank you for help!!

Sorry, I am yet not allowed to attach pics for better description

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

My first guess is that -3.40282e+38 is the Null value and that your colleague's system correctly recognized and handled that but it doesn't work on your system.

Try specifying the null value or just create a colormap that makes sense.

share|improve this answer
    
And i bet the histogram is as well messed up. You could edit your dems with python/gdal/numpy to assign null values, it's much easier to create a colormap and assigning -3.40282e+38 as white/black/cyan/whatever –  nickves Sep 14 '12 at 14:00
    
I don´t no where the mistake is, but I just created a new one, very easy, with reasonable classes, god I was blocked..thank you! :-) histogram next step .. –  oppia04 Sep 14 '12 at 15:08
1  
@oppia04: great! please consider accepting the answer if your problem is solved. –  underdark Sep 14 '12 at 16:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.