Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to compile Qgis 1.8 in linux debian squeeze (following the instructions in INSTALL.txt). During 'make' I get the following error:

[ 40%] Building CXX object src/providers/spatialite/CMakeFiles/spatialiteprovider.dir/qgsspatialiteprovider.cpp.o /usr/local/qgis-1.8.0/src/providers/spatialite/qgsspatialiteprovider.cpp: In function ‘bool initializeSpatialMetadata(sqlite3*, QString&)’: /usr/local/qgis-1.8.0/src/providers/spatialite/qgsspatialiteprovider.cpp:4972: error: ‘spatial_ref_sys_init’ was not declared in this scope make[2]: * [src/providers/spatialite/CMakeFiles/spatialiteprovider.dir/qgsspatialiteprovider.cpp.o] Error 1 make[1]: [src/providers/spatialite/CMakeFiles/spatialiteprovider.dir/all] Error 2 make: ** [all] Error 2

Any help to solve this?


share|improve this question
Hello, did you solve this? I have exactly the same problem... – jorgeas80 May 12 '13 at 11:47

I solved it compiling libspatialite by myself. I used this version:, and executed the classical ./configure & make & make install

After that, ensure the compiled version of libspatiallite is selected during ccmake step (SPATIALITE_INCLUDE_DIR and SPATIALITE_LIBRARY vars)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.