Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I try create a new DataBase, Spatialite plugin return the dialog error box:

The SQL query seems to be invalid. no suck table: views_goemetry_columns

When I click in OK button, a second dialog box (Transform DataBase into SpatiaLite) is open with the text :

This DataBase seems to be a valid SQLite DataBase but not a valid SpatiaLite One
Would you like QSpatiaLite to automatically transform it to SpatiaLite (information won't be lost) ?

When I click in the YES button, a new dialog error box open with the text:

Unable to convert Database to SpatiaLite

When I click in OK button, another dialog error box open with the text:

The SQL query seems to be invalid.

The DataBase was set up, but I cant import spatial layers. How resolve this problem?

share|improve this question
2  
"whe I try to create a new database" Using what? –  Ragi Yaser Burhum Sep 18 '12 at 14:17
    
I got the same problem, so thank you for your answer, but how do you then import spatialitegui into QGIS ? –  user14363 Jan 18 '13 at 9:51
    
You don't import spatialite_gui. You just use the file that this tool creates. Thats the point of spatialite / sqlite. –  BradHards Jan 18 '13 at 10:01
    
To say it the other way round: You create the database table with the gui, but you can fill/modify/show the data with Qgis. –  Andre Joost Jan 18 '13 at 11:07

1 Answer 1

as Ragi Yaser Burhum alread stated: >>"when I try to create a new database" Using what?<<

the easiest and safest way to create a spatialite-database : use the free spatialitegui ( gaia-gis.it/fossil/spatialite_gui/index) from the spatialite developer and then import into qgis... seems like your database is missing the geometry columns and is therefore a simple nonspatial sqlite databse

share|improve this answer
1  
gaia-gis.it/fossil/spatialite_gui/index simply copying & pasting the URL above doesn't work since it's using https –  Rayner Sep 18 '12 at 16:42
    
@Rayner: thanks for correcting this ! Kurt –  Kurt Sep 18 '12 at 17:30
    
Rayner and Kurt, –  Ernesto Sep 20 '12 at 19:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.